Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Gateway Timeout - The gateway did not receive a...

Gateway Timeout - The gateway did not receive a... 23 Jul 2018 10:49 #48985

  • agnoletti
  • agnoletti's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Marco
  • Posts: 29
  • Thank you received: 0
When trying to edit the content of a specific page (built by PageBuilder CK) of my website ( http://www.capitanoagnoletti.it/soldo ), since today, when I save the page I always get the following error message and what was done is not saved at all:

Gateway Timeout
The gateway did not receive a timely response from the upstream server or application.


To access that page, you need to login first using the following credentials:
username ********
password ********

Can you see where the actual error come from?
Thank you in advance!
Marco

Please Log in or Create an account to join the conversation.

Last Edit: by agnoletti. Reason: Hiding personal details not needed to be shown anymore

Gateway Timeout - The gateway did not receive a... 23 Jul 2018 11:01 #48986

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21175
  • Karma: 427
  • Thank you received: 2680
Hi
you must contact your host provider to check that. By my side there is no reason for this problem and I have no possibility to check if this is really a problem coming from Page Builder CK
This seems more related to your server. But if you get an error from your host provider about Page Builder CK, then we can check together with detailed infos
CEd

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Gateway Timeout - The gateway did not receive a... 23 Jul 2018 11:39 #48991

  • agnoletti
  • agnoletti's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Marco
  • Posts: 29
  • Thank you received: 0
Thank you. I'll let you know the answer from the hosting service (SiteGround). Marco

Please Log in or Create an account to join the conversation.

Last Edit: by agnoletti. Reason: Provisional reply not needed anymore because of my following reply

Gateway Timeout - The gateway did not receive a... 23 Jul 2018 12:51 #48992

  • agnoletti
  • agnoletti's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Marco
  • Posts: 29
  • Thank you received: 0
Here is the answer from Siteground support team:

Todor Ivanov

Support Guru
Posts: 1406
Posted On 23 Jul, 2018 06:57 CDT

Hello Marco Agnoletti,

Thank you for contacting our help desk!

I've checked on the web-server error logs and there are quite a few error messages related to your capitanoagnoletti.it website:

Code:
[Mon Jul 23 10:27:43.304670 2018] [:warn] [pid 43125] [client 151.29.3.28:39118] Timeout waiting for output from CGI script /home/marcoa51/public_html/administrator/index.php, referer: www.capitanoagnoletti.it/administrator/i...age&layout=edit&id=8


From the extract above you can find the following URL which seems to be referring to the "PageBuilder CK" extension:

Code:
www.capitanoagnoletti.it/administrator/i...age&layout=edit&id=8


Having said this, I've now increased the following PHP variables to their max allowed value in hopes that this solves the issue:

Code:
max_input_time = 120
max_execution_time = 120


However if this solution doesn't help you should contact the developers of this extension for assistance in solving this issue. We'll be happy to assist with any suggestions or fixes they may propose.

Of course, you're also more than welcome to contact us again should you have additional questions and concerns.

Best Regards,

Todor Ivanov
Senior Technical Support


I tried once more to modify my webpage www.capitanoagnoletti.it/soldo but still getting the same "504 Gateway Timeout" error message.
Is there something you can suggest about the issue related to PageBuilder CK, mentioned by Siteground?
Thank you!

Please Log in or Create an account to join the conversation.

Gateway Timeout - The gateway did not receive a... 23 Jul 2018 13:12 #48993

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21175
  • Karma: 427
  • Thank you received: 2680

From the extract above you can find the following URL which seems to be referring to the "PageBuilder CK" extension:

Code:
www.capitanoagnoletti.it/administrator/i...age&layout=edit&id=8

or course, this is the url of your page ! ;)
when you edit an article you got an url like "option=com_content", this does not mean that the joomla core is in cause ...

you can
1/ create a new page and see if it works
2/ import your existing page into a joomla article (switch to page builder in the article, then use the "load a page" button), then save it and see if you got the same message. in this case the article will be saved by joomla!, not by Page Builder CK

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Gateway Timeout - The gateway did not receive a... 24 Jul 2018 16:47 #49016

  • agnoletti
  • agnoletti's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Marco
  • Posts: 29
  • Thank you received: 0
1. I made a copy of the affected page and I tried to work on that copy, but I still kept receiving the "Gateway timeout" error message when saving (and the page was not saved).

2. I could not be interested in trying to save that page (built using PageBuilder CK) into an article because I needed to put some modifications in what was already written there.

I SOLVED THE MATTER by:
- creating a module into which I put the part of the page I wanted to modify
- inserting that module in the desired position of the page (using the option of inserting a module given by PageBuilder CK)

It worked fine!

NOTE: the only page that gives me the error of "Gateway timeout" is the largest in my website.
Could that be because there are too many elements in there?

Please Log in or Create an account to join the conversation.

Last Edit: by agnoletti. Reason: Changing the icon to "SOLVED"

Gateway Timeout - The gateway did not receive a... 24 Jul 2018 19:04 #49021

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21175
  • Karma: 427
  • Thank you received: 2680
ok, interesting. Yes it could be the problem that your servers can not handle your request because the input POST is too big
this is why I aksed to check with the hosting support which is the only one that can see the exact cause.
I think that the problem is most related to the post size than the post time

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer
  • Page:
  • 1
Time to create page: 0.203 seconds

Fast and powerful creation, customizable and responsive.

Read More

Qui est en ligne

We have 549 guests and 4 members online