logo maximenuck 64Maximenu CK

Maximenu CK is a Joomla megamenu dropdown with nice effects.

logo slideshowck 64Slideshow CK

Slideshow CK, nice effect with this slideshow responsive design.

logo accordeonmenuck joomlaAccordeon Menu CK

Accordeon menu CK is a joomla accordion menu with mootools effects.

logo template creator joomlaTemplate Creator CK

Template Creator CK is a tool to create your own Joomla! templates.

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Les composants en panne

Les composants en panne 02 May 2017 14:21 #41682

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Bonjour Cedric,
j'espère que tout va bien de ton côté.
Je ne sais pas si ce topic sera bien classé sur le forum, car il concerne d'autres composants en rapport avec la mise à jour de Joomla 3.7. Je propose que tu crée une catégorie "report de bugs global" ou qq chose dans cet esprit.

Eh oui...
J'ai fait la mise à jour de Joomla vers la 3.7, et depuis j'ai eu quelques soucis et en particulier pour le Slideshow CK. Après avoir fait cette Update, je me retrouve avec un message d'erreur au moment où j'affiche l'ensemble des modules:
"Erreur
Unknown column 'client_id' in 'where clause' "
Quand j'essayes d'éditer un Slideshow CK, j'ai ce message à nouveau. Et dans "Assignation des menus", je ne peux plus choisir les menus.
On a bien la liste déroulante:
* Sur toutes les pages (ça marche mais cela affiche le module sur toutes les pages)
* Aucune page (on a plus rien...)
* Uniquement les liens sélectionnées...
* Tout sauf...

Voilà, les deux dernières options n'affichent pas les menus, voir image attaché.

Est-ce que d'autres personnes t'on fait par de cette situation?
Cette erreur viendrait-elle de la mise à jour Joomla ou plutôt d'une erreur au moment de l'exécution de la mise à jour?

Je te serai très reconnaissant si tu peux me donner des indications pour ça.

En complément d'info voici les alertes que j'ai dans "Extensions / Vérification de la Base de Données"
***********
La version (Aucun) du schéma de la base de données ne correspond pas à la version (3.7.0-2017-04-19) du CMS.
La table 'prefix_newsfeeds' ne contient pas la colonne 'link' avec le type VARCHAR(2048) (du fichier 3.6.3-2016-08-15.sql).
La table 'prefix_fields' n'existe pas (du fichier 3.7.0-2016-08-29.sql).
La table 'prefix_fields_categories' n'existe pas (du fichier 3.7.0-2016-08-29.sql).
La table 'prefix_fields_groups' n'existe pas (du fichier 3.7.0-2016-08-29.sql).
La table 'prefix_fields_values' n'existe pas (du fichier 3.7.0-2016-08-29.sql).
La table 'prefix_menu_types' ne contient pas la colonne 'client_id' (du fichier 3.7.0-2016-11-19.sql).
La table 'prefix_languages' ne doit pas contenir l'index 'idx_image' (du fichier 3.7.0-2016-11-21.sql).
La table 'prefix_extensions' ne contient pas la colonne 'package_id' (du fichier 3.7.0-2016-11-24.sql).
La table 'prefix_contact_details' ne contient pas la colonne 'language' avec le type varchar(7) (du fichier 3.7.0-2017-02-17.sql).
La table 'prefix_languages' ne contient pas la colonne 'asset_id' avec le type int(10) unsigned (du fichier 3.7.0-2017-03-03.sql).
La table 'prefix_menu_types' ne contient pas la colonne 'asset_id' avec le type int(10) unsigned (du fichier 3.7.0-2017-03-03.sql).
La table 'prefix_finder_links' ne contient pas la colonne 'description' avec le type text; (du fichier 3.7.0-2017-03-19.sql).
**************

Merci beaucoup.
@ plus.
Ricardo
Attachments:
The administrator has disabled public write access.

Les composants en panne 02 May 2017 14:24 #41683

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Pour info encore:
L'erreur:
"Erreur
Unknown column 'client_id' in 'where clause'"

et le problème de "Assignation de menus" existe dans d'autres modules aussi.

Donc ça ne vient pas de SlideShow CK...
The administrator has disabled public write access.

Les composants en panne 02 May 2017 14:29 #41684

  • ced1870
  • ced1870's Avatar
  • NOW ONLINE
  • Administrateur
  • Posts: 17491
  • Thank you received: 2232
  • Karma: 389
salut
il y a un sujet sur le forum joomla FR ici
forum.joomla.fr/showthread.php?220494-Er...-suite-maj-Joomla-37

ça devrait t'aider :)

pour tous les soucis généraux, je te conseille vivement le forum.joomla.fr
après je comprends qu'ici le souci soit plus lié au slideshow ;)
CEd
Joomlack Webmaster and Developer
The administrator has disabled public write access.

Les composants en panne 02 May 2017 14:39 #41685

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Je suis désolé. J'ai été trop rapide peut être. Au départ j'ai eu l'impression que ça venait de la MAJ, mais que cela était lié aux questions de version de PHP. Il me semble que nous serons confrontés à cela tôt ou tard.

Merci encore et je regarde tout de suite le Forum Joomla.
@ plus.
The administrator has disabled public write access.

Les composants en panne 19 Jun 2017 13:31 #43130

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Bonjour Cedric,
Je reviens par ici afin de clarifier ma question. Cela fait déjà un moment que je voulais reprendre cet échange.

Tu m'as indiqué de voir le forum joomla et cela est très instructif en effet, mais cela n'a pas résolu le problème, qui se présente différemment selon le site.
La plupart de mes sites sont hébergés chez OVH et on est en php 5.6. J'ai compris qu'il faudra envisager un passage à Php 7.

Entre temps j'ai laissé en version 3.65, mais un jour ou l'autre il faudra quand même que je passe à 3.7xx.


Du coup, afin de procéder par étapes, je repose 3 questions pour commencer et en attendant je vais refaire la manip sur mon serveur de Dev.

1°) Les composants CK sont bel et bien compatibles avec la version 3.7 de Joomla, n'est-ce pas?
2°) Et selon toi ce n'est pas de ce côté là qu'il faut chercher...
3°) Et tu n'a pas eu d'autres échos sur le même sujet.

Merci.
@Plus
The administrator has disabled public write access.

Les composants en panne 19 Jun 2017 13:38 #43131

  • ced1870
  • ced1870's Avatar
  • NOW ONLINE
  • Administrateur
  • Posts: 17491
  • Thank you received: 2232
  • Karma: 389
salut
Les composants CK sont bel et bien compatibles avec la version 3.7 de Joomla,
oui :)
Et selon toi ce n'est pas de ce côté là qu'il faut chercher.
à mon avis c'est ta migration joomla 3.7 qui te pose souci
Et tu n'a pas eu d'autres échos sur le même sujet.
pas pour mes extensions

si tu édites un autre module que le slieshow, tu n'as pas le souci dans l'onglet d'assignation ?
CEd
Joomlack Webmaster and Developer
The administrator has disabled public write access.

Les composants en panne 20 Jun 2017 09:13 #43159

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Rebonjour CEd
si tu édites un autre module que le slieshow, tu n'as pas le souci dans l'onglet d'assignation ?
A priori non. Je vais vérifier pour en être sur.

Nouvelles infos:

1) J'ai fait la MAJ sur 2 sites sur les serveurs de développement et j'ai eu des situations différentes. J'ai enregistré une vidéo et je mettrai le lien si besoin.
1.1) Sur le premier j'ai eu un msg d'erreur à l'installation et en effet plusieurs choses étaient cassées. En passant par "corriger la DB" ça a remis de l'ordre et les images du slideshow ce sont affichés
1.2) Sur le deuxième la MAJ a été réussie sans aucun mgf d'erreur, mais les images du Slideshow ne sont plus là... ce matin je vérifierai les paramètres et je te tiendrai au courant.

2) J'ai aussi commencé un nouveau site qui est déjà en 3.72 et le slideshow semble fonctionner.

Donc je continuerai mes recherches et je vais poster une demande sur le forum de Joomla.

Dès que j'aurai du nouveau je reviendrai par ici pour donner une solution et expliquer ce que j'ai trouvé.
Cela peut servir à tout le monde.

Bonne journée à 35°...
Ricardo
The administrator has disabled public write access.

Les composants en panne 20 Jun 2017 09:16 #43160

  • ced1870
  • ced1870's Avatar
  • NOW ONLINE
  • Administrateur
  • Posts: 17491
  • Thank you received: 2232
  • Karma: 389
merci pour tes infos :)
dans l'autre site où tu n'as pas d'erreur, tu as essayé de corriger la DB aussi ?

bonne journée à toi aussi
CEd
Joomlack Webmaster and Developer
The administrator has disabled public write access.

Les composants en panne 20 Jun 2017 13:30 #43171

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
dans l'autre site où tu n'as pas d'erreur, tu as essayé de corriger la DB aussi ?
j'ai vérifié s'il y avait des messages et rien à signaler. J'ai quand même fait "corriger" pour voir si joomla fesait qq chose, mais tout était ok.

"La structure des tables de la base de données est à jour."

*******
Et là je viens de faire un autre test:
j'ai créé un nouveau module Slideshow avec les images de base, puis j'ai fait du copier coller de mes images dans la zone d'images et ça affiche bien le nouveau slideshow avec les images.
C'est quand même incroyable ça.

merci encore pour ta patience.
@plus
The administrator has disabled public write access.

Les composants en panne 20 Jun 2017 15:40 #43173

  • RBandeira
  • RBandeira's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 47
  • Thank you received: 3
  • Karma: 0
Encore une info:
* sur ce site on a mis plusieurs Slideshow (tu dois te souvenir du site d'archi)
aucun affiche d'image (indiqué plus haut) sur aucun des slideshows
* en bas de chaque section on a mis un module "image DJ" car à l'époque il n'y avait pas encore le slide CK. Du coup on a testé la version beta qui est encore sur le site et je viens de constater que là aussi on a un message

Composant/Slide CK (2eme option styles)
******************************************
Une erreur s'est produite

500 Table 'piximainbpbd71px.#__sliderck_styles' doesn't exist Table 'bd71.#__sliderck_styles' doesn't exist
*****************************************


Pg01.jpg



Ma conclusion pour l'instant est:
- La version 3.72 corrige un problème que j'avais au départ (le bug de l'affectation de menu pour un module)
- très souvent ce sont les images des modules CK qui sont affectées même si le module s'affiche correctement.

Là je dois partir, alors je continuerais après.


Merci encore.
Ricardo
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.240 seconds
Powered by Kunena Forum

Mentions légales

Site made by Cédric KEIFLIN

Privacy policy

Copyright © 2010 - 2015

http://forum.joomlack.fr is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla!® name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Qui est en ligne

We have 95 guests and 2 members online