Problem in helper.php causing issues

Problem in helper.php causing issues was created by Mati

Posted 13 years 2 months ago #44
I have been playing around with Maximenu for a little while now and absolutely love it but.. I receive error messages when enabling some other modules such as ChronoForms and I also receive the errors when running a search in the default Joomla Search box.

Error Below,

Notice: Trying to get property of non-object in /clientdata/apache-www/x/x/domain.com.au/www/modules/mod_maximenu_CK/helper.php on line 138

Notice: Trying to get property of non-object in /clientdata/apache-www/x/x/domain.com.au/www/modules/mod_maximenu_CK/helper.php on line 139

Notice: Trying to get property of non-object in /clientdata/apache-www/x/x/domain.com.au/www/modules/mod_maximenu_CK/helper.php on line 140

Notice: Trying to get property of non-object in /clientdata/apache-www/x/x/domain.com.au/www/modules/mod_maximenu_CK/helper.php on line 142


Any ideas how I can resolve this? It's getting to a point where I might have to switch to a different menu system :(
by Mati

Please Log in or Create an account to join the conversation.

Replied by ced1870 on topic Re: Problem in helper.php causing issues

Posted 13 years 2 months ago #45
hi
I've recently discovered a similar issue that I have to fix. Could you tell me which version of joomla (1.5 or 1.6 ) and maximenu (4.16..) you are using ?
CEd

Joomlack Webmaster and Developer

by ced1870

Please Log in or Create an account to join the conversation.

Replied by Mati on topic Re: Problem in helper.php causing issues

Posted 13 years 2 months ago #46
Joomla 1.6.1
Maximenu_CK for Joomla 1.6 ( Version 5.8 )

After searching around online the problem seems to be pretty common however no one has posted a fix yet.

Do you have a rough ETA of when you might release a patch/update?
Last Edit:13 years 2 months ago by Mati
Last edit: 13 years 2 months ago by Mati.

Please Log in or Create an account to join the conversation.

Replied by ced1870 on topic Re: Problem in helper.php causing issues

Posted 13 years 2 months ago #47
I'll do it ASAP.

please check with the new helper I attach, replace the file in the module folder and tell me if it solved.
CEd


Attachment helper.zip not found

Joomlack Webmaster and Developer

Last Edit:13 years 2 months ago by ced1870
Attachments:
Last edit: 13 years 2 months ago by ced1870.

Please Log in or Create an account to join the conversation.

Replied by Mati on topic Re: Problem in helper.php causing issues

Posted 13 years 2 months ago #48
I have just tested it with the default Joomla Search box and the problem is now resolved.

I no longer have Chronoforms installed so I cant test that right now but I will try and confirm that it works in the next day or so.

Thanks heaps Ced, your truly are a dedicated developer.
by Mati

Please Log in or Create an account to join the conversation.

Time to create page: 0.712 seconds

Fast and powerful creation, customizable and responsive.

Read More

We have 1025 guests and one member online