Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Slowness problem

Slowness problem 25 Nov 2021 11:31 #62506

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 63
  • Thank you received: 2
Dear Cedric,

I am using slideshowCK in most of my articles to display a Flickr album. The call to the module is after the "read only", but this is evidently nevertheless affecting the loading time of the blog layout page, which displays 9 articles at a time. The result is that, on the (seemingly not very good) Siteground webhosting I'm currently using, there is a delay of about 30 seconds to load the page.

I did not realise what was causing this until I went through deactivating modules and plugins and found that when I deactivated Peter van Westen's "modules anywhere" plugin, which I use to call the SlideshowCK modules, the page loaded rapidly. Following Peter's advice, I then tried replacing these modules with a simple custom module, and then the page also loaded rapidly.

I am not suggesting there is any problem with SlideshowCK. I am just wondering if you see anyway to solve this problem or if I would need to call these Flickr albums in a different way?

I was surprised that code after the "read only" affects the loading of the blog page, which does not display the slide-show.

Also, on a cheap LWS hosting that I just set up to test things, the page displays in about 15 seconds. I don't know if a more expensive hosting would be better or not.

Best wishes,

Alan

Please Log in or Create an account to join the conversation.

Last edit: by Aks.

Slowness problem 25 Nov 2021 15:22 #62507

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 25394
  • Karma: 427
  • Thank you received: 3205
HI
I'm surprised like you that the content not loaded can affect your page
please try to load the module using the native joomla solution : {loamoduleid XX} or {loadposition XX}
putting the tag (you can use the editor button to create it) it will be replaced with the module

tell me if you have the same problem in this case
Also confirm that you are using the native joomla blog layout, and not a third party extension
CEd
Joomlack Webmaster and Developer

Please Log in or Create an account to join the conversation.

Slowness problem 26 Nov 2021 10:41 #62518

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 63
  • Thank you received: 2
Thank you Cedric.

Yes, if I switch to {loamoduleid XX} AND disable Peter's Modules Anywhere plugin, then the front page loads pretty much instantaneously.

(Yes, I am using the native Joomla blog layout. I do have a third party template.)

However, the individual articles take a number of seconds to load with the SlideshowCK module calling the Flickr album.

I was thinking that perhaps it might take the system some time to figure out which module(s), if any, to display on the page,because I have so many modules. However, in that case, I would have thought the front page would also take a long time to display.

Therefore, it appears to be the loading of the slide-show with the Flickr album which is taking some time. This could be due to the time taken to fetch the images, but if I just put the Flickr embed code, there is no apparent delay.

Do you have any idea how I could speed up the display of the slide-show or get the article to display first while waiting for the images?

Thanks,

Alan

Please Log in or Create an account to join the conversation.

Slowness problem 26 Nov 2021 13:10 #62521

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 25394
  • Karma: 427
  • Thank you received: 3205

Yes, if I switch to {loamoduleid XX} AND disable Peter's Modules Anywhere plugin, then the front page loads pretty much instantaneously.

.
ok then the problem from the blog comes from the fact that the module anywhere loads the module in the blog even if not needed

the individual articles take a number of seconds to load with the SlideshowCK module calling the Flickr album.

yes, I think that this is related to the fact that it will get the data from Flickr, I shall add a sort of caching
for now I'm busy, but you can remind me in 2 weeks :)

CEd
Joomlack Webmaster and Developer

Please Log in or Create an account to join the conversation.

Slowness problem 26 Nov 2021 18:23 #62528

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 63
  • Thank you received: 2
Thank you, Cedric, I'll try to remember.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.199 seconds

Fast and powerful creation, customizable and responsive.

Read More

Qui est en ligne

We have 686 guests and 2 members online