Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Slideshow ck not showing on front page

Slideshow ck not showing on front page 31 Oct 2018 09:05 #49837

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 1
Hi Cedric,

For some reason, Slideshow ck has stopped displaying displaying on the front page of the website at www.europe.upf.org . I see the source code on the page, so I assume this is not a problem with your module, but probably some kind of JQuery or Javascript problem, but I can't seem to figure out what exactly is causing it. If you have any ideas, it would be greatly appreciated. I don't see anything in the template about loading a Javascript library, so it must be coming from some other extension, I suppose.

Alan

Please Log in or Create an account to join the conversation.

Slideshow ck not showing on front page 31 Oct 2018 09:13 #49838

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 20284
  • Karma: 418
  • Thank you received: 2583
Hi
it seems that you have multiple slideshows in the page, but at least one of them has the JS/CSS code loaded, but not the content
Please unpublish all your slideshows, then publish them one by one and see which ones are working, and which ones not.
Then tell me the result
CEd

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Slideshow ck not showing on front page 31 Oct 2018 09:40 #49840

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 1
Thank you so much, Cedric. I disabled these modules and the slideshow (that was supposed to be there) now displays on the front page. The others were not supposed to be there. It must have been some change in the Advanced Module Manager I'm using that caused them to display on the front page.

Please Log in or Create an account to join the conversation.

Slideshow ck not showing on front page 31 Oct 2018 09:43 #49841

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 20284
  • Karma: 418
  • Thank you received: 2583
ok great to know
I know that yesterday there was some issues in Adv manager, to check with Peter because he has released some new versions today

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Slideshow ck not showing on front page 31 Oct 2018 09:47 #49842

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 1
Yes, I thought it must be this, but when I installed his latest version, or even an older version, it fixed the errors I was getting, but my slideshow didn't come back! Spent hours trying to figure out why. Many thanks for your help.

Please Log in or Create an account to join the conversation.

Slideshow ck not showing on front page 04 Nov 2018 08:15 #49895

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 1
Actually, I still have the problem. I thought it was because of the problems with the Advanced Module Manager, but this turns out not to be the case. They think that perhaps the multiple occurrences were already occurring before but that this was not creating a problem. Indeed they were surprised that it was seemingly not possible to have multiple occurrences of the slideshow on the same page.

The fact is that I have slideshows being called in the articles which appear on the front page. These individual slideshows are set in the advanced module manager to not appear on the front page itself. However, because Modules Anywhere is set to "Ignore Module Assignments" = yes, they are nevertheless coming up to some extent on the front page. If I set "Ignore Module Assignments"to no, then the slideshows don't appear in the articles.

The strange thing is that I didn't have this problem until very recently. I hadn't really thought about the logic of it all, because it was working.

Do you have any ideas? My basic need is to have one Slideshow CK module displaying normally on the front page and many articles, each containing one [Modules anywhere] call to a Slideshow CK module, without these modules displaying anywhere else, especially on the front page, if possible without having to edit all of my numerous modules!

Alan

Please Log in or Create an account to join the conversation.

Slideshow ck not showing on front page 04 Nov 2018 09:38 #49900

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 20284
  • Karma: 418
  • Thank you received: 2583

it was seemingly not possible to have multiple occurrences of the slideshow on the same page.

this is false :) you can have multiple slideshows on the same page, this works.

For now, if I understand your problem, you are asking about modules assignment. This is not managed by slideshow ck itself, but managed by joomla or adv modules manager

The original problem listed here was that one of your modules had no content in the page, but anyway have the script called
I can check by my side if I find a turn-around solution

CEd

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Slideshow ck not showing on front page 04 Nov 2018 09:44 #49901

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 20284
  • Karma: 418
  • Thank you received: 2583
please replace this file
www.dropbox.com/s/gg290w45yyckfwn/camera.min.js?dl=0

into
modules/mod_slideshowck/assets

then clear your browser cache, and tell me if the problem is fixed

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Slideshow ck not showing on front page 04 Nov 2018 16:19 #49907

  • Aks
  • Aks's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 1
Hi Cedric,

I hasten to say that I did not intend to imply that the problem is originating from your module.

The fix you gave me does seem to work. I have no idea what you did.

I do still see the various pieces of code in the source code of the page, such as "#camera_wrap_480 ...", where 480 is the [unwanted] module number, but the wanted slideshow does now display on the front page. Does it matter that these pieces of code are there?

Many thanks,

Alan

Please Log in or Create an account to join the conversation.

Slideshow ck not showing on front page 04 Nov 2018 18:37 #49910

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 20284
  • Karma: 418
  • Thank you received: 2583

The fix you gave me does seem to work. I have no idea what you did.

great ! :)
I have updated the script to not execute if the module code is missing, event if this has no sense basically because the module itself loads the JS

I have just checked your website frontpage, and I see the slideshow running. Is there any other problem ? because I was thinking that this was the original issue

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer
  • Page:
  • 1
  • 2
Time to create page: 0.211 seconds

Fast and powerful creation, customizable and responsive.

Read More

Qui est en ligne

We have 396 guests and no members online