Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Problème avec K2 et positionnement de modules

Problème avec K2 et positionnement de modules 24 Jan 2013 20:04 #8348

Avec le template que j'ai créé, c'est impossible d'afficher deux colonnes avec le composant k2 dans le main center en page d'accueil ou sous n'importe quel onglet de menu. Ma colonne de droite doit toujours rester visible. Comment puis-je faire en sorte que ça s'affiche selon les paramètres de k2?

J'ai un autre problème avec le positionnement des modules, quand il y en a 4 dans un bloc, c'est bien, toutefois, j'ai besoin à deux endroits dans le site qu'il y ait 2 ou 3 modules dans un bloc, mais que les modules ne soient pas égaux, j'ai écrit la largeur dans le template, mais ils ne s'affichent pas correctement, c'est comme si les modules obéissaient à la règle de pourcentage réparti de façon égale entre le nombre de modules, comment puis-je régler ce problème?

Merci. :)

Please Log in or Create an account to join the conversation.

Problème avec K2 et positionnement de modules 25 Jan 2013 09:14 #8355

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 21036
  • Karma: 425
  • Thank you received: 2662
salut

1/ je ne sais pas comment K2 gère l'affichage de ses colonnes, mais j'imagine que le composant a ses propres CSS ? je ne vois pas pourquoi le template te poserait un souci à ce niveau la.

2/ là dans le fichier index.php il y a des classes qui sont automatiquement affectées en fonction du nombre de modules, si tu gères ça à ta manière tu peux simplement supprimer le code dans le fichier index.php

CEd

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Problème avec K2 et positionnement de modules 28 Jan 2013 15:56 #8428

Merci pour les réponses rapides. Je ne me suis pas encore attaquée à mon premier problème, mais en ce qui concerne le deuxième, j'ai essayé de supprimer le code que je crois qui commande les modules dans l'index.php, mais ça enlève tout le bloc au complet.

Je ne suis vraiment pas une pro, est-ce que tu peux m'indiquer quel bout du code il faut enlever exactement?

Merci.

Please Log in or Create an account to join the conversation.

Problème avec K2 et positionnement de modules 29 Jan 2013 09:01 #8442

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 21036
  • Karma: 425
  • Thank you received: 2662
sinon va dans le fichier template.css et vires les classes

.full {
width: 100%;
}

.demi {
width: 50%;
}

.tiers {
width: 33.33%;
}

.quart {
width: 25%;
}

ce sont celles qui définissent les largeurs des modules

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Problème avec K2 et positionnement de modules 30 Jan 2013 20:05 #8497

Bonjour Ced,

J'ai enlevé les classes dont je n'avais pas besoin et ça fonctionne bien. Merci!

Je reviens à mon problème avec K2 pour le nombre de colonnes, j'ai inspecté l'élément avec Google Chrome et Firefox et je peux voir que le site prend la commande des colonnes, mais elles ne s'affichent apparemment pas (voir image_1)et je suis allée sur les forums de K2 et j'ai pu déduire que c'était un conflit avec le css du template. J'ai également essayé K2 sur un autre de mes sites avec les mêmes paramètres et les colonnes s'affichent sans problème.

J'ai dû faire une erreur au niveau du bloc Contenu principal, mais je ne sais pas quoi changer pour que ça s'affiche correctement.

Merci de m'aider encore une fois. :)

Please Log in or Create an account to join the conversation.

Problème avec K2 et positionnement de modules 30 Jan 2013 22:22 #8503

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 21036
  • Karma: 425
  • Thank you received: 2662
ben donnes moi l'url du site qui déconne, je vais voir si je trouve qqch

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Problème avec K2 et positionnement de modules 30 Jan 2013 22:32 #8508

Le site est [url=http://humago.ca.]http://humago.ca[/url].

Je t'ai mis en pièce jointe la maquette de l'accueil.


Merci encore.

Geneviève
Attachments:

Please Log in or Create an account to join the conversation.

Problème avec K2 et positionnement de modules 30 Jan 2013 22:40 #8509

  • ced1870
  • ced1870's Avatar
  • Offline
  • Administrateur
  • Administrateur
  • Posts: 21036
  • Karma: 425
  • Thank you received: 2662
les classes utilisées par K2 dans tes deux sites ne sont pas les memes, il manque un float left sur les éléments pour les aligner. En tout cas rien à voir avec le template, ce sont des css spécifiques à K2 (peut etre si tu as chargé un theme spécifique ou un truc du genre)

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer
  • Page:
  • 1
Time to create page: 0.267 seconds

Fast and powerful creation, customizable and responsive.

Read More

Qui est en ligne

We have 284 guests and one member online