Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: version 2.1.0 installation

version 2.1.0 installation 24 Aug 2012 14:37 #5105

  • vezid
  • vezid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 0
Salut Cedric,

Félicitations pour la nouvelle version de Template Creator.
Je suis en Joomla 2.5.6, en localhost avec la nouvelle version 2.1.0. de Template Creator

Pour l'installation j'ai effectué la mise à jour sur la version précédente, un message d'erreur est apparu que j'ai oublié de noter.
J'ai donc désinstallé complétement Template Creator et réinstallé la nouvelle version.

Maintenant j'ai un problème dans l'onglet Template Creator Gestion des templates: Edition, l'action sur les boutons (Enregistrer et fermer, enregister et Close) ne produit aucun effet et le système se bloque. Ceci aussi bien sur les nouveaux templates exemple avec templatecreator_demo6 ou avec un ancien template importer.

De même si je coche "Enregistrer directement dans le template lors de la création du package (si installé)", et si je clique sur le bouton enregistrer et fermer, rien ne se produit et je reste bloqué.
Observe-tu les mêmes effets?

Aurai je oublié d'installer une extension?
J'observe dans la gestion des extensions de Joomla!
Template Creator CK Administration Composant 2.1.0 2011
Template Creator Package Site Paquet 2.1.0 Juillet 2012
templatecreatorck Site Template 1.0.0 Septembre 2011
Ces extensions sont bien activées.

Merci de ton aide
Cordialement
Philippe

Please Log in or Create an account to join the conversation.

Last Edit: by vezid.

Re: version 2.1.0 installation 24 Aug 2012 15:25 #5106

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21348
  • Karma: 427
  • Thank you received: 2699
salut
hmm, normalement pas de message à la mise à jour, ça m'aurait intéressé de le connaitre. tant pis
et le problème tu l'as aussi avec le template demo1 préinstallé ?
tu as quel navigateur ? tu as testé avec Firefox ?
Ced

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Re: version 2.1.0 installation 24 Aug 2012 15:45 #5107

  • vezid
  • vezid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 0
salut cedric,
j'ai également le problème avec demo1.
Testé avec Firefox 14.0.1.
Philippe

Please Log in or Create an account to join the conversation.

Re: version 2.1.0 installation 24 Aug 2012 15:49 #5108

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21348
  • Karma: 427
  • Thank you received: 2699
tu peux voir dans la console du navigateur si tu as une erreur javascript ?
aucun souci de mon coté, testé sur plusieurs sites en upgrade ou install fraiche.
sinon faudrait essayer de le mettre en ligne. et aussi essayer de l'installer sur un autre site pour voir

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Re: version 2.1.0 installation 26 Aug 2012 05:41 #5114

  • vezid
  • vezid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 0
Salut Ced,
Merci pour tes réponses qui m'ont permis d'approfondir et de trouver la solution.
Après recherche j'ai constaté qu'avec Chrome tout était OK, en désactivant des modules complémentaires(web developer et Aptana debugger) de FIREFOX c'est revenu ok, en les réactivant c'est resté OK.

Néanmmoins sous Chrome et Firefox lorsque j'effectue la désinstallation du paquet de la nouvelle version j'ai le message suivant
"Échec du chargement du fichier XML
C:\xampp\htdocs\CITF\jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml
XML: failed to load external entity "file:///C:/xampp/htdocs/CITF/jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml"
Désinstallation de paquet : fichier manifest manquant
Erreur : Paquet n'a pas pu être désinstallé."

On est obligé de désinstaller chaque élément du paquet (Template Creator CK Administration Composant 2.1.0 2011 et
templatecreatorck Site Template 1.0.0 Septembre 2011) et ensuite dans la base de supprimer dans la table extension Template Creator Package Site Paquet 2.1.0 Juillet 2012.
J'ai vérifié les tables template Creator sont bien supprimés et les dossiers Templateck dans les composants administrator et site sont bien supprimés.

Je pense qu'il manque un fichier.
Cordialement
Philippe

Please Log in or Create an account to join the conversation.

Re: version 2.1.0 installation 26 Aug 2012 06:20 #5115

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21348
  • Karma: 427
  • Thank you received: 2699
salut
merci pour les infos.
pour ton probleme je vois que tu as un chemin qui pointe vers jupgrade, es-tu sur de ne pas avoir un souci de config sur ton site ?
sinon tu peux dézipper le pkg, et installer les deux zip qui sont dedans séparément.
Tiens moi au jus
Ced
The following user(s) said Thank You: vezid

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer

Re: version 2.1.0 installation 27 Aug 2012 20:26 #5155

  • vezid
  • vezid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 0
Salut Ced,
l'installation s'effectue correctement, la désinstallation des éléments aussi sauf le package
Précédemment en localhost sous xammp windows je constate sous Chrome et Firefox lorsque j'effectue la désinstallation du paquet de la nouvelle version j'ai le message suivant
"Échec du chargement du fichier XML
C:\xampp\htdocs\CITF\jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml
XML: failed to load external entity "file:///C:/xampp/htdocs/CITF/jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml"
Désinstallation de paquet : fichier manifest manquant
Erreur : Paquet n'a pas pu être désinstallé."

Si on observe bien le Directory Selector DS est incorrect, il est / au lieu de \ donc c'est normal qu'il ne trouve pas le fichier qui est bien présent.

Egalement dans le fichier C:\xampp\htdocs\CITF\jupgrade\administrator\components\com_templateck\views\templateck\view.html.php si j'ajoute 2 lignes de test
* private function to check if the template templatecreatorck is installed
     */
    function _checkIfTemplateInstalled() {
	$app = JFactory::getApplication();
        if (JFolder::exists(JPATH_ROOT.DS.'templates'.DS.'templatecreatorck')) {
* lignes ajoutées		
		$app->enqueueMessage( JText::_('DS '.DS), 'error' );
		$app->enqueueMessage( JText::_(JPATH_ROOT.DS.'templates'.DS.'templatecreatorck'), 'error' );
* fin de lignes ajoutés		
            return;
        } else {
            $app->enqueueMessage( JText::_('TEMPLATE_TEMPLATECREATORCK_NOT_INSTALLED'), 'error' );
        }
Je constate la réponse suivante :
DS \
        C:\xampp\htdocs\CITF\jupgrade emplates emplatecreatorck
ce qui confirme un probléme de DS dans un de tes programmes car je n'ai aucun souci avec les autres extensions installées et avec ta version précédente.

Peux tu m'indiquer également le fonctionnement "Enregistrer directement dans le template lors de la création du package (si installé)". Pas trouvé d'explication dans la notice.
Je pensais que si je crée un template CITF et qu'il était installé une première fois il s'enregistrait dessus. Après essai cela ne fonctionne pas. Est ce encore un problème de DS? le test ci-dessus teste la présence de templatecreatorck, n'est pas plutôt CITF qu'il aurait fallu tester?

Bon courage pour trouver l'anomalie.
Cordialement
Philippe

Please Log in or Create an account to join the conversation.

Last Edit: by vezid.

Re: version 2.1.0 installation 27 Aug 2012 20:32 #5157

  • vezid
  • vezid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 0
Salut Ced,
L'installation s'effectue correctement, la désinstallation des éléments aussi sauf le package
Précédemment en localhost sous xammp windows je constate sous Chrome et Firefox lorsque j'effectue la désinstallation du paquet de la nouvelle version j'ai le message suivant
"Échec du chargement du fichier XML
C:\xampp\htdocs\CITF\jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml
XML: failed to load external entity "file:///C:/xampp/htdocs/CITF/jupgrade/administrator/manifests/packages/pkg_templatecreatorck.xml"
Désinstallation de paquet : fichier manifest manquant
Erreur : Paquet n'a pas pu être désinstallé."

Si on observe bien le Directory Selector DS est incorrect, il est / au lieu de \ donc c'est normal qu'il ne trouve pas le fichier qui est bien présent.

Egalement dans le fichier C:\xampp\htdocs\CITF\jupgrade\administrator\components\com_templateck\views\templateck\view.html.php si j'ajoute 2 lignes de test
* private function to check if the template templatecreatorck is installed
*/
function _checkIfTemplateInstalled() {
$app = JFactory::getApplication();
if (JFolder::exists(JPATH_ROOT.DS.'templates'.DS.'templatecreatorck')) {
[b]* lignes ajoutées
$app->enqueueMessage( JText::_('DS '.DS), 'error' );
$app->enqueueMessage( JText::_(JPATH_ROOT.DS.'templates'.DS.'templatecreatorck'), 'error' );
* fin de lignes ajoutés	[/b]
return;
} else {
$app->enqueueMessage( JText::_('TEMPLATE_TEMPLATECREATORCK_NOT_INSTALLED'), 'error' );
}
Je constate la réponse suivante :
[b]DS \
C:\xampp\htdocs\CITF\jupgrade emplates emplatecreatorck[/b]
ce qui confirme un probléme de DS dans un de tes programmes car je n'ai aucun souci avec les autres extensions installées et avec ta version précédente.

Peux tu m'indiquer également le fonctionnement "Enregistrer directement dans le template lors de la création du package (si installé)". Pas trouvé d'explication dans la notice.
Je pensais que si je crée un template CITF et qu'il était installé une première fois il s'enregistrait dessus. Après essai cela ne fonctionne pas. Est ce encore un problème de DS? le test ci-dessus teste la présence de templatecreatorck, n'est pas plutôt CITF qu'il aurait fallu tester?

Bon courage pour trouver l'anomalie.
Cordialement
Philippe

Please Log in or Create an account to join the conversation.

Re: version 2.1.0 installation 31 Aug 2012 04:12 #5229

Hi there,

I don't speak French, so I will have to write this in English.

This morning I purchased Template Creator CK and installed it on on my site. I first uninstalled an older demo version -2.09b. After installing the PKG 2.1.1, I got the same problems as reported here. I couldn't save, nor save&close, nor just close. This happened/happens in Google Chrome.

Firefox 14 works fine however.

Not a big deal, although I mainly use Google Chrome.

Thought I let you know.

Cheers

Rutwin

Please Log in or Create an account to join the conversation.

Re: version 2.1.0 installation 31 Aug 2012 04:19 #5230

  • ced1870
  • ced1870's Avatar
  • Away
  • Administrateur
  • Administrateur
  • Posts: 21348
  • Karma: 427
  • Thank you received: 2699
Hi
@rutwin : thank you for this information, I have to check this :)

@vezid : je n'avais pas vu ton post,

Si on observe bien le Directory Selector DS est incorrect, il est / au lieu de \ donc c'est normal qu'il ne trouve pas le fichier qui est bien présent.

ça c'est plutot un probleme dans joomla me semble-t-il. Et DS n'est plus nécessaire, PHP gère tout seul.

Je pensais que si je crée un template CITF et qu'il était installé une première fois il s'enregistrait dessus

exact, une fois le template installé, tu coches la case et tu fais "créer le package". Ca devrait marcher :)

Please Log in or Create an account to join the conversation.

Joomlack Webmaster and Developer
  • Page:
  • 1
  • 2
Time to create page: 0.219 seconds

Fast and powerful creation, customizable and responsive.

Read More

Qui est en ligne

We have 530 guests and 3 members online